Back to overview
Resolved

SSO login unavailable — WorkOS global outage

Jul 16, 2026 at 9:44am UTC
Affected services
eu.orbio.work
us.orbio.work

Resolved
Jul 16, 2026 at 10:48am UTC

WorkOS deployed the fix and confirmed the incident is resolved

Created
Jul 16, 2026 at 9:44am UTC

Our third-party single sign-on (SSO) provider is experiencing a major global outage. As a result, users may be unable to log in to Orbio via SSO.

Impact: Users authenticating through SSO cannot access the platform. Users with active sessions are unaffected. Candidate-facing flows (WhatsApp, SMS/RCS, calls, scheduling) are not impacted — this is limited to SSO-based login to the Orbio web app.

Current status: We are monitoring WorkOs status page (https://status.workos.com/)